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What's New in R:BASE 11 (Version 11.0)

Official Release Version

Thursday, November 20, 2025

UPDATE 3

Build: 11.0.3.11120

Requested Enhancements 09/06/2025 - 11/20/2025

Date ImplementedItem Description

11.0.3.11120Release Build:
 

01. 11/12/2025 Utilities - The Data Dictionary includes a new toggle button to control whether or not the utility uses the
Windows clipboard to pass information between the Data Dictionary and destination control (original
behavior). The new behavior transfers the captured data directly, not via the clipboard.

02. 10/13/2025 Settings - A new RESET setting has been implemented which controls whether or not RESET commands
are added to output from UNLOAD commands. The default is ON. 

    SET RESET ON/OFF

03. 10/08/2025 Settings - A new QUOTEBLANKS setting has been implemented which controls whether R:BASE will add
quotes to blank strings derived from variables, which occurs when using a dotted/ampersand variable
and the NULL setting is all blanks. The quotes added to the blank string is the current QUOTES character.
The default is ON.

    SET QUOTEBLANKS ON/OFF

04. 10/06/2025 Forms - The Tile Menu control was updated with the added "On Home Click" EEP to execute when focus
is directed to the main page.

05. 09/17/2025 Commands - The in-memory table limit has been increased from 25 to 1000.

06. 09/11/2025 Views - In-memory views has been implemented, where the temporary view is stored in memory, not
temporary files.

    CREATE INMEMORY VIEW CustomerContact +
    (CustID,Company,ContID,ContFName,ContLName,+
    ContPhone,ContEMail,LastContactDate) AS  +
    SELECT T1.CustID,T1.Company,T2.ContID,T2.ContFName,T2.ContLName,+
    T2.ContPhone,T2.ContEMail,T2.LastContactDate +
    FROM Customer T1,Contact T2 +
    WHERE T1.CustID = T2.CustID
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11.0.3.11120Release Build:
 

07. 09/08/2025 Form Designer - The Tab Order settings has been enhanced to select an object on the form canvas with
[Ctrl+MouseHover] even while the modal Tab Order Settings dialog is displayed. The feature allows for
the selected form object to be highlighted in the Tab Order dialog for easier recognition of the control,
especially on forms with many objects. Note that the feature only works on the list of objects in the lower
child controls list view. If the control being hovered is not in the child controls list view, then the auto-
selection will not take place.
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Reported Bug Fixes 09/06/2025 - 11/20/2025

Date FixedItem Description

11.0.3.11120Release Build:
 

01. 11/17/2025 Forms - The filtering performance in DB Grid and Enhanced DB Grid controls has decreased in the recent
September 05 update.

02. 11/14/2025 Database Explorer - When an underscore is defined within an object's name (table, form, report, etc.), the
underscore is listed at the end of an alphabetically sorted list. This sort differs to how operating systems
sort the underscore in folders, and also how areas of R:BASE sort objects. For example, in the
Import/Export dialog, the table names with an underscore in the name are listed before letters.

03. 11/14/2025 File Gateway - When the [Alt] is pressed during the number of rows processed import dialog, the import
process incorrectly stops.

04. 11/12/2025 Utilities - When displaying all details (Name, Table Name, Comment, Date/Time) in the Data Dictionary,
include the missing Version column. Also, the Table Name caption should read "Table/View Name" as
both may be assigned.

05. 11/07/2025 Commands - When table structure is unloaded, the comments and rules are written as ANSI while the rest
of the table definition is UTF8, resulting in an incorrect mixed content.

06. 11/05/2025 Reports/Labels - When printing a report to a PDF file from the Print Preview screen, expected data at the
bottom of the first page is not included.

07. 11/04/2025 Forms - When using a DB Tree List control and selecting a node via EEP code, the data change event is
not triggered.

08. 10/31/2025 Forms - When displaying a list view who's dynamic WHERE clause includes an ampersand variable, the list
view content is not populated. The ampersand variable for the WHERE clause can be NULL or contain a
value.

09. 10/28/2025 File Gateway - When importing a fixed format text file, not all of the expected rows are loaded into the
table. The file being imported has 52,225 lines of records. However, when the import is completed, there
are only 40,707 rows in the table. The initial "Preparing records ..." status in the "number of rows loaded"
dialog is where the incrementing import value stops at 40,707 rows.

10. 10/28/2025 File Gateway - If a duplicate import is performed, while selecting to clear the existing records on the final
screen, the subsequent import is much slower than the initial import.

11. 10/28/2025 File Gateway - When reviewing the break line wizard screen for a fixed format import, the file display of
character coordinates resets incorrectly when the mouse button is clicked, held down, and released within
the horizontal scroll bar.

12. 10/28/2025 File Gateway - The "Importing..." dialog with the rows Added/Processed is incorrectly on top of all opened
windows for the operating system. The dialog should be specific to R:BASE.

13. 10/27/2025 File Gateway - When loading a specification file for a fixed width format text file, the assigned starting
and ending break lines for the desired data sections are not retained in the break line wizard screen. The
GUI appears with lines, however the locations are incorrect.

14. 10/27/2025 Forms - When using the PROPERTY command to alter the background color of a DB Grid control, the
color is not updated as expected.
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11.0.3.11120Release Build:
 

15. 10/24/2025 Report/Label Designer - When adding/removing items within a report band, the "Number of Objects: #"
caption on the band is not automatically updated. The band must be physically moved with the mouse, or
the designer must be closed and reopened in order for the "Number of Objects: #" caption to appear as
expected.

16. 10/24/2025 Data Designer - When clicking to save table changes, if you click on the designer background the "Save
Changes" dialog is incorrectly placed behind the R:BASE window. This causes confusion as the Save
confirmation dialog will also be behind the main R:BASE window.

17. 10/24/2025 File Gateway - When importing a XLSX spreadsheet file into a table a "file limit" message appears. The file
does import into the table as expected using version X.5.

18. 10/23/2025 Settings - Steps may be repeated where the configuration file may be wiped out of all settings/content.

19. 10/23/2025 Settings - The Configuration Settings dialog can incorrectly display TMP as the SCRATCH setting when
the setting is not defined as such.

20. 10/22/2025 Report/Label Designer - After a text variable expression is modified with added static text, the variable on
the report does not reflect the change after saving and previewing the report.

21. 10/21/2025 Form Designer - When using the green arrow buttons to move a selected item up or down the list, if a
button is clicked many times and the item moves up/down beyond the visible scope, the arrow button
can keep being pushed, but you do not know where the current item is located in the order. Please
ensure the selected item stays visible when moving up and down the list.

22. 10/21/2025 Report/Label Designer - When static text labels are defined as bold, and then the bold style is removed,
the report preview still displays the text as bold.

23. 10/20/2025 File Gateway - When loading a file for an import and after the R:BASE background is clicked, the import
progress dialog is now behind the R:BASE window. The behavior can be confusing as the user does not
know that the import is still taking place, especially when switching to another program and back to
R:BASE. The import dialog should remain on top of the R:BASE window when running.

24. 10/20/2025 External Form Designer - When selecting "Form > Save Form As" from the menu bar or the "Save Form
As" button, the file name field is blank. Please update the file name field to provide the "existing" external
form file name, to easily define a new file name that is similar to the existing file name, without having to
type out the file name.

25. 10/16/2025 WHERE Builder - The "Add Column" button, or the action of double clicking on a column name in the
"Select Columns" list, incorrectly overwrites the value in the Windows clipboard.

26. 10/16/2025 Form Designer - When using the Form Designer menus and property editors, the clipboard content may
be incorrectly overwritten when using the Data Dictionary to capture information.

27. 10/15/2025 Forms - When using Variable Edit fields with dynamic WHERE clauses, the expected results are not
displayed in pop-up menus.

28. 10/13/2025 Forms - The drag-and-drop functionality for use in list view controls does not behave as expected.

29. 10/09/2025 Report/Label Designer - The "Edit > Code" menu option in the Form Designer provides search options
when the "Code" tab is viewed and no EEP has been opened in the Editor. Even though code may be
searched in reports/labels, the "Edit > Code" menu option is missing.

30. 10/08/2025 ODBC - When SATTACHing a table with column names as reserved words when ANSI is set OFF, the table
is attached but cannot be opened in the Data Browser.

31. 10/07/2025 File Gateway - When a new table import takes place and R:BASE recognizes that there are data type
differences between the existing columns and the new columns and a new column name is automatically
generated, an 18-character limit is incorrectly assigned to the new column name  length.
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32. 10/07/2025 Forms - When a Tile Menu is used to display the Detail control, the title gets updated with the Detail's
caption. But, if the prior title is shorter than the new one, the new title is drawn in the rectangle occupied
by the previous title (which is not as wide).

33. 10/06/2025 Forms - When launching a form with a Web Browser control using MS Edge as the browser engine on a
new Windows 11 operating system, the Web Browser does not display the content as expected. 

A newer WebView2Loader.dll file is included with product updates and installers.

34. 10/06/2025 Label Designer - When the designer is open and the database is disconnected, the "Close the Report
Designer first" message is displayed.  The message should read "Close the Label Designer first" if that
specific module is open.

35. 10/02/2025 Data Types - The internal handling of VARBIT variables has been corrected.

36. 10/02/2025 Database Explorer - When copying a report, the "Reset Version Number" option is not checked by
default, which differs from when copying a form.

37. 10/02/2025 Report Designer - Reports with many rich text controls may fail to open in the designer.

38. 10/01/2025 Print Preview - When printing a report to the screen which has over 10,000 pages, the page count value is
truncated.

39. 10/01/2025 Form Designer - When tabbing from field to field for DB Edit objects which are located on the form
background layer, the Static Text, Panels, and several of the Form Designer toolbars blink/refresh each
time the [Tab] key is pressed.

40. 10/01/2025 Form Designer - When using the Tab Order Settings dialog on a form with many controls, the focus upon
objects in the lower list view would automatically change if there were objects "behind" the Tab Order
dialog.

41. 09/22/2025 Forms - The DB Tree Grid control does not correctly utilize the R:BASE session's regional settings.

42. 09/22/2025 File Gateway - When multiple specification files (.rgw) reside in the same folder, where the file copies
were made by using a copy/paste of the file in Windows Explorer, the .rgw files incorrectly display in the
File Gateway with the same exact name.

The file list was updated to display the .rgw file name and the specification name.

43. 09/22/2025 Data Designer - When reviewing rules and sliding the Message/Where column separator to the left to see
large WHERE definitions, the column incorrectly resets back to the prior location when switching to
another R:BASE tab (R> Prompt, Editor, etc.) and back to the Data Designer.

44. 09/22/2025 Forms - When using dynamic tiles within the Tile Menu control, the tile generation does not correctly
process the carat "^" line break character.

45. 09/18/2025 Database Explorer - Exceptions can occur when creating, deleting, and recreating a database using a
command file at the R> Prompt.

46. 09/18/2025 Data Browser - A minimized state can be incorrectly persisted after reopening the Data Browser, which
appears as though R:BASE is not responding, when in fact it is showing a modal form that is minimized.

47. 09/18/2025 Data Browser - The modal Data Browser minimize behavior has been updated, where instead of
minimizing the modal form, the entire application is minimized instead.

48. 09/17/2025 Commands - When unloading a table with a column which is defined with a default value containing an
apostrophe, the UNLOAD output does not allow for the table to be recreated.

49. 09/17/2025 Reports/Labels - Rich text content can appear incorrectly within Mail Merge-enabled Rich Text controls.
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50. 09/12/2025 Report/Label Designer - The Grid Option check box settings are not saved when checked or unchecked
within a session, and are always checked when the designer is started.

51. 09/12/2025 Form Designer - The "View > Snap to Grid" and "View > Show Grid" menu bar settings are not saved
when toggled off within a session, and are always checked when the designer is started.

52. 09/09/2025 Reports/Labels - When a DB Barcode object defined with the Auto Size and Auto Font Size properties
checked using Code 128, the barcode does not expand as expected.

53. 09/08/2025 Commands - When processing a dotted VARCHAR variable in a WHILE loop, the variable value is
incorrect.

54. 09/08/2025 Forms - The Enhanced DB Grid drop-down filter logic has been updated where the drop-down items are
now updated to contain only valid values relative to the existing filters.
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